AWS Outage
Incident Report for EASE
Resolved
AWS has resolved the issue. Closing the ticket on our side.
Posted Sep 28, 2022 - 21:55 UTC
Update
Update from AWS:
10:59 AM PDT We continue to see elevated error rates and latencies for invokes on API Gateway endpoints in the US-WEST-2 Region. While engineers continue to work towards root cause, we have deployed traffic filters from sources with significant increases in traffic prior to the event. As a result of these traffic filters, we are seeing a reduction in error rates and latencies, but continue to work towards full recovery. Although error rates are improving, we do not yet have an ETA for full recovery. The issue is also affecting API requests to some AWS services, including those listed below. Amazon Connect is experiencing increased failures in handling new calls, chats, and tasks as well as issues with user login in the US-WEST-2 Region. We will continue to provide updates as we progress.
Posted Sep 28, 2022 - 18:09 UTC
Update
Update from AWS: 10:33 AM PDT [10:33 AM PDT] We are investigating increased error rates for invokes in the US-WEST-2 Region. We do not yet have a root cause, but are investigating multiple potential root causes in parallel. In addition, we are implementing filters on inbound traffic from a set of sources with recent significant traffic shifts, which may help mitigate the impact. We do not yet have a solid ETA, but will continue to provide updates as we progress.
Posted Sep 28, 2022 - 17:37 UTC
Update
We are continuing to monitor for any further issues.
Posted Sep 28, 2022 - 17:10 UTC
Monitoring
We are being affected by the current AWS outage. Our users are experiencing intermittent connectivity issues on all environments.
We are monitoring the status of the issue and will update the status as we see changes in the AWS outage.
Posted Sep 28, 2022 - 17:07 UTC
This incident affected: EASE Audit Platform (iOS Mobile App, Android Mobile App, govcloud.ease.io, Global.ease.io).