Maintenance for the deployment of our 3.80 release is currently ongoing.
✅ Mobile Apps • The iOS and Android apps have been updated to version 3.80 in the Apple App Store and Google Play Store. • The latest APK is also available for direct download here: https://download.ease.io/mobile/latest/
✅ Microsoft Build • The latest Microsoft build is pending approval in the Microsoft App Store. • The executable can be downloaded here: https://download.ease.io/microsoft/latest/
✅ Valeo Environment • The Valeo environment is now available.
✅ GovCloud Environment • The GovCloud environment is now available.
✅ Global/EU Environment • The Global/EU environment is now available.
⚠️ Main Production and Environment • There are slight delays in the updates on main production environment (app.ease.io) • Validation of the 3.80 update is in progress.
We will continue to provide updates as validation continues. Thank you for your patience. We will be extending the maintenance for 30 minutes while we validate the updates.
Posted Jul 13, 2025 - 16:59 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 13, 2025 - 15:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Jul 11, 2025 - 00:02 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Jul 10, 2025 - 23:59 UTC
Scheduled
EASE will be in maintenance mode Sunday, July 13, from 8:00–10:00 AM Pacific (15:00–17:00 UTC) for a full deployment of the 3.80 release.
Action Required: Update your EASE Mobile App at 8:00 AM. Older versions will not work after this update.