Undergoing Production Database maintenance
Incident Report for EASE
Resolved
Maintenance is complete.
Posted May 20, 2023 - 00:00 UTC
Monitoring
We are undergoing production database maintenance. We will be in maintenance mode for 30 minutes.
Posted May 19, 2023 - 23:31 UTC
This incident affected: EASE Audit Platform (app.ease.io, iOS Mobile App, Android Mobile App).