We are experiencing an issue with our hosting platform
Incident Report for EASE
Resolved
We have not had any reports of issues since we made the fix. Please contact support if you need any assistance.

The cause of the issue was due to an issue with our Domain registrar. We have resolved the issue with them.
Posted May 19, 2023 - 15:03 UTC
Update
We are seeing that our endpoints are now accessible in 90% of locales. We are continuing to monitor while the updates to our DNS are being propagated. We have had a few notifications from customers that the site is still not accessible but we have seen that it's coming back quickly in all regions.
Posted May 19, 2023 - 14:09 UTC
Monitoring
A fix has been made. Our ease.io domains are coming back up. We are monitoring the situation.
Posted May 19, 2023 - 13:09 UTC
Identified
We have identified the cause of the issue. Please use our easeinc.com endpoints for now instead of ease.io.
app.easeinc.com
global.easeinc.com
govcloud.easeinc.com
valeo.easeinc.com
Posted May 19, 2023 - 12:52 UTC
Investigating
We are currently experiencing an issue with their DNS routing. We are working on the issue and will update this as we learn more.
Posted May 19, 2023 - 12:23 UTC
This incident affected: EASE Audit Platform (app.ease.io, iOS Mobile App, Android Mobile App, govcloud.ease.io, Global.ease.io) and EASE Insights.