Undergoing Database Maintenance
Incident Report for EASE
Resolved
We have completed our database maintenance. Should you experience any issues, please contact our support.
Posted May 06, 2023 - 18:12 UTC
Monitoring
From 7AM PT to 11AM PT May 6th, we are undergoing database maintenance. Thank you for your patience.
Posted May 06, 2023 - 14:28 UTC
This incident affected: EASE Audit Platform (app.ease.io, iOS Mobile App, Android Mobile App).