Unscheduled maintenance
Incident Report for EASE
Resolved
Our maintenance has completed. We are sorry for the inconvenience.
Posted Dec 15, 2022 - 04:22 UTC
Identified
We are currently undergoing some unscheduled maintenance. We are working on data optimization and will update this status page as we move further in the process.
Posted Dec 14, 2022 - 23:13 UTC
This incident affected: EASE Audit Platform (app.ease.io, iOS Mobile App, Android Mobile App).