Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 30, 2025 - 15:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 28, 2025 - 17:28 UTC
Scheduled
Our production environment will undergo database maintenance on **Sunday, March 30th, 2025, starting at 8:00 AM (PDT) for approximately 2 hours.** We apologize for any inconvenience and appreciate your patience as we enhance our services for your benefit.
As always, you can visit the [EASE System Status Portal](https://status.ease.io/) for updates on system availability. If you have any questions, please contact us at support.ease.io.
Posted Mar 28, 2025 - 17:28 UTC
This scheduled maintenance affected: EASE Audit Platform (app.ease.io, iOS Mobile App, Android Mobile App).