All Findings List Issue Update
Incident Report for EASE
Resolved
All Findings have been recovered. Thank you for your patience. If you are still experiencing any issues, please contact our support.
Posted Apr 04, 2023 - 19:36 UTC
Update
We have restored the correct status on All Findings up until 5AM PT this morning. We are still working on restoring the correct status on Findings submitted between 5AM-9AM PT.
Posted Apr 04, 2023 - 17:32 UTC
Identified
We are currently investigating a database error affecting the All Findings list view for customers who access EASE via app.ease.io. We are working on a fix for the issue and will provide updates throughout the day until it is resolved. We apologize for any inconvenience this may cause.
Posted Apr 04, 2023 - 16:30 UTC
This incident affected: EASE Audit Platform (app.ease.io, iOS Mobile App, Android Mobile App).