Maintenance on our Global Environment
Incident Report for EASE
Resolved
Our Database maintenance on our global environment is complete.
Posted Jun 02, 2023 - 22:55 UTC
Monitoring
We are currently undergoing maintenance on our Global Environment. This maintenance is going on longer than expected, we have identified the delay and are continuing to move along.
Posted Jun 02, 2023 - 21:57 UTC
This incident affected: EASE Audit Platform (Global.ease.io).