System outage
Incident Report for EASE
Resolved
This incident was resolved. No other issues have been reported.
Posted Oct 04, 2023 - 18:43 UTC
Monitoring
We believe that we have resolved the issue. We are monitoring the environment.
Posted Sep 20, 2023 - 03:58 UTC
Investigating
We are currently experiencing an issue with our production environment, app.ease.io. We are investigating the issue and will update as we have more information
Posted Sep 20, 2023 - 03:41 UTC
This incident affected: EASE Audit Platform (app.ease.io, iOS Mobile App, Android Mobile App).