Our scheduled maintenance ran slightly over time, but it is now fully complete and services are back to normal.
Posted May 11, 2025 - 16:18 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 11, 2025 - 15:00 UTC
Scheduled
Our Global environment will undergo database maintenance on **Sunday, May 11th, 2025, starting at 8:00 AM (PST) for approximately 1 hour.** We apologize for any inconvenience and appreciate your patience as we enhance our services for your benefit. As always, you can visit the [EASE System Status Portal](https://status.ease.io/) for updates on system availability. If you have any questions, please contact us at support.ease.io.
Posted May 10, 2025 - 03:42 UTC
This scheduled maintenance affected: EASE Audit Platform (Global.ease.io).