Scheduled Database Maintenance.
Incident Report for EASE
Resolved
Scheduled Database Maintenance Completed. Thank you for your patience.
Posted Aug 14, 2023 - 23:26 UTC
Investigating
We are currently conducting scheduled Database maintenance. This should only take 30 minutes.
Posted Aug 14, 2023 - 23:01 UTC
This incident affected: EASE Audit Platform (app.ease.io, iOS Mobile App, Android Mobile App).