Deployment Status Update

Incident Report for EASE

Resolved

All systems are fully operational and performing normally. The deployment has been completed successfully, and no further impact is expected.

We sincerely apologize for any disruption this may have caused and thank you for your patience and understanding.
Posted Apr 16, 2026 - 20:45 UTC

Update

The deployment has been completed successfully and all services are now operating normally. We scaled our infrastructure to address the earlier issues, and systems have been fully restored.
We appreciate your patience throughout this process and apologize for any inconvenience experienced during the deployment. If you encounter any further issues, please reach out to our support team.
Thank you for your continued trust.
Posted Apr 16, 2026 - 20:31 UTC

Monitoring

We are currently performing a scheduled production deployment and are experiencing some temporary issues during the rollout. The underlying infrastructure updates have now completed successfully, and we are finalizing the deployment of the corresponding application changes to restore full functionality.

Some users may continue to experience intermittent issues until the deployment is fully complete. We appreciate your patience as we work to resolve this as quickly as possible and will provide an update once the deployment has been finalized.

Thank you for bearing with us.
Posted Apr 16, 2026 - 20:28 UTC
This incident affected: EASE Audit Platform (app.ease.io).