Our development team has confirmed that the issue was fully resolved within 17 minutes. All four of our production environments were affected, but only two—GovCloud and Global-EU—experienced an impact that was visible to customers. The issue stemmed from an unexpected change in requirements from our hosting platform. Once identified, our team quickly implemented a fix. We’re now working with the platform’s support team to understand why the change was applied ahead of schedule, and we’re rolling out preventative updates across all environments to ensure continued reliability. We appreciate your patience as we continue to strengthen our systems.
Posted Mar 28, 2025 - 15:50 UTC
Monitoring
We believe that we have identified the issue and have applied a change that appears to be fixing the issue. Please clear your cache if you see translation issue and if you continue to experience issues, please contact our support at support@ease.io
Posted Mar 28, 2025 - 00:30 UTC
Investigating
We are currently experiencing an issue affecting our translation services. Our development team is actively investigating the cause, and we will provide updates as soon as more information becomes available. We appreciate your patience.
Posted Mar 28, 2025 - 00:11 UTC
This incident affected: EASE Audit Platform (app.ease.io, iOS Mobile App, Android Mobile App, govcloud.ease.io, Global.ease.io, Valeo.ease.io/valeo.easeinc.com).