Cancelling the unscheduled maintenance for tonight.
Posted Jan 14, 2026 - 23:55 UTC
Scheduled
The EASE Production platform will undergo emergency maintenance today, January 14, starting at 9:00 PM PT (05:00 UTC on January 15) for approximately 30 minutes. This downtime is required to perform critical database optimization.
As always, you can visit the EASE System Status Portal (status.ease.io) for updates on system availability. If you have any questions, please contact us at support@ease.io.
Posted Jan 14, 2026 - 23:04 UTC
This scheduled maintenance affected: EASE Audit Platform (app.ease.io).