Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 12, 2025 - 15:00 UTC
Scheduled
Please note that the EASE platform will undergo database optimization maintenance on **Sunday, October 12, 2025, from 8:00–10:00 AM PDT (15:00–17:00 UTC).**
All four environments will be included in this maintenance window, with approximately 30 minutes of downtime per environment in the following order:
1. US Production 2. Global EU 3. Valeo 4. Gov
This work is part of ongoing database optimization efforts to enhance system performance and reliability across all environments.
As always, you can visit the EASE System Status Portal @ https://status.ease.io for updates on system availability. If you have any questions, please contact support@ease.io.
Posted Oct 10, 2025 - 23:05 UTC
This scheduled maintenance affected: EASE Audit Platform (app.ease.io, iOS Mobile App, Android Mobile App, govcloud.ease.io, Global.ease.io, Valeo.ease.io/valeo.easeinc.com).